Install OPNET 14.5 on Windows 8 with Visual Studio 2012

I made a video one year ago, in intalling OPNET 14.5

I don't want to create it again, just I refer you to it. Also, for those who needs the Variables and Paths, I copied them here:



What we need before installing OPNET:
Installed Windows on computer (As an example, I installed Windows 8 x64 (or 64 bit) on my computer)
Installed Microsoft Visual Studio 2012 ((As an example, I installed Microsoft Visual Studio 2012 x86 (or 32 bit))

Please note that you can install Microsoft Visual Studio 2012 64bit or 32bit but I installed it in 32bit release while my Windows 7 is 64 bit. So you see all of Microsoft Visual Studio 2010 installed path is "C:\Program Files (x86)\Microsoft Visual Studio 11.0"
We need this path later.


What we need for installing OPNET is source of OPNET (We will install these respectively):
modeler_145A_PL8_7808_win.exe
modeler_docs_02-Sep-2008_win.exe
models_145A_PL8_24Sep08_win.exe
OPNET.Modeler.14.5.License.Maker-FFS.exe

We MUST add some variables in system path before running OPNET. I will show you the name and path of variables, then I will add them to System Variables.

OK. When the OPNET and its educational license are installed, if your Windows is x64 or 64 bit, you will see two exe file for running OPNET which are named:
OPNET Modeler 14.5 (64-Bit)
OPNET Modeler 14.5
Which one you should select to run? Actually it depends on the release of Microsoft Visual Studio 2012 which is installed on your machine. For example I installed Microsoft Visual Studio 2012 x86 or 32-bit on my Windows, so as you see that all of Variables were in " C:\Program Files (x86)\Microsoft Visual Studio" path, I must run OPNET Modeler 14.5 and NOT OPNET Modeler 14.5 (64-Bit).

OK! I think you can now follow the video. I hope it is useful.


Video Link:




Variables and Paths
DevEnvDir
C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE\

Framework35Version
v3.5

FrameworkDir
C:\Windows\Microsoft.NET\Framework\

FrameworkVersion
v2.0.50727

INCLUDE
C:\Program Files (x86)\Microsoft Visual Studio 11.0\VC\atlmfc\include;C:\Program Files (x86)\Microsoft Visual Studio 11.0\VC\include\;C:\Program Files (x86)\Windows Kits\8.0\Include\um\;C:\Program Files (x86)\Windows Kits\8.0\Include\shared\

LIB
C:\Program Files (x86)\Microsoft Visual Studio 11.0\VC\atlmfc\lib\;C:\Program Files (x86)\Microsoft Visual Studio 11.0\VC\lib;C:\Program Files (x86)\Windows Kits\8.0\Lib\win8\um\x86\

LIBPATH
C:\Windows\Microsoft.NET\Framework\v3.5\­;C:\Windows\Microsoft.NET\Framework\v2.0­.50727\;C:\Program Files (x86)\Microsoft Visual Studio 11.0\VC\atlmfc\lib\;C:\Program Files (x86)\Microsoft Visual Studio 11.0\VC\lib\

Path
C:\Program Files (x86)\Microsoft Visual Studio 11.0\VC\bin\;C:\Windows\Microsoft.NET\Fr­amework\v3.5\;C:\Windows\Microsoft.NET\F­ramework\v2.0.50727\;C:\Program Files (x86)\Microsoft Visual Studio 11.0\VC\vcpackages\;C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE\;C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\Tools\;C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0A\Bin\

VCINSTALLDIR
C:\Program Files (x86)\Microsoft Visual Studio 11.0\VC\

VS100COMNTOOLS
C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\Tools\

VSINSTALLDIR
C:\Program Files (x86)\Microsoft Visual Studio 11.0\

WindowsSdkDir
C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0A\

22 comments:

Majid Heidari said...

HI,i had followed the steps provided by you but getting error message as:
"the opnet installer has not detect a compiler on this system"
please help me about this error.

Alireza Rezvani said...

Hi Majid,

Two reasons come to mind. First, be sure that you have installed Visual Studio in your machine, because OPNET needs C++ objects
Second, please be sure that you have inserted/Edited the valuables and paths on your system value.
Cheers

Raphael said...

Is it possible to install OPNET in ubuntu system???

Raphael Agboola said...

Thanks for the tutorial. Please is it possible to install OPNET and ns-3 on ubuntu distros. Appreciate

Alireza Rezvani said...

@Raphael
Hi,

Thank you for your comment. Actually I have no idea about installing OPNET on Ubuntu Linux but I am sure you can install ns-3 on Suse Linux (check: http://www.cbt4all.com/search/label/ns-3) and Ubuntu Linux (check: https://www.nsnam.org/wiki/Installation)

Thanks

milad mohabati said...

HI,i had followed the steps provided by you but getting error in DES

plz help me to fix error




<<< Recoverable Error >>>
Win32: unable to launch program with CreateProcess():
LINK /DUMP /SYMBOLS "C:\Program Files\OPNET\14.5.A\models\std\links\dpt_propdel_bgutil.dev64.i0.ps.obj"

----
<<< Recoverable Error >>>
Win32: unable to launch program with CreateProcess():
LINK /DUMP /SYMBOLS "C:\Program Files\OPNET\14.5.A\models\std\links\ecc_zero_err_bgutil.dev64.i0.ps.obj"

----
<<< Recoverable Error >>>
Win32: unable to launch program with CreateProcess():
LINK /DUMP /SYMBOLS "C:\Program Files\OPNET\14.5.A\models\std\links\error_zero_err.dev64.i0.ps.obj"

----
<<< Recoverable Error >>>
Win32: unable to launch program with CreateProcess():
LINK /DUMP /SYMBOLS "C:\Program Files\OPNET\14.5.A\models\std\ethernet\eth_hub_txdel_bgutil.dev64.i0.ps.obj"

----
<<< Recoverable Error >>>
Object repository construction failed
due to errors encountered by the binder program (bind_so_msvc)
T (0), EV (-), MOD (NONE), PROC (sim_load_repos_rebuild)
----
Errors reported by the binder program follow
(these messages have been saved in (C:\Users\shinobi\op_admin\tmp\bind_err_2364):
bind_so_msvc: Unable to execute bind program (Win32 error code: 2)

Check that Visual C++ has been installed correctly, and that

its BIN directory is included in the Path environment variable.


----
<<< Program Abort >>>
Error encountered rebuilding repository -- unable to proceed
T (0), EV (-), MOD (NONE), PROC (sim_load_repos_load)

Alireza Rezvani said...

@Milad
Hi,

Thanks for your comment.

Two reasons come to mind. First, be sure that you have installed Visual Studio in your machine, because OPNET needs C++ objects
Second, be sure that you have inserted/Edited the valuables and paths on your system value.
In general, these types of errors are related to the above reasons.

Cheers

milad mohabati said...

hi Alireza
Thanks for the reply
All exact installation process
but again I am faced with the same problem

Alireza Rezvani said...

@Milad

If you are sure all things are correct (Have installed VS and change/insert paths, with paying attention to version and edition), sorry then, I have no idea

If you find the solution, please write it here for the others

:-)

Morteza Hadizadeh said...

please help me
All exact installation process but I see Error
<<< Recoverable Error >>>
Process model (bursty_source) compilation failed
due to error on source line (20)
Errors given in file (C:\Users\admin\op_admin\tmp\cc_err_5036)
----
<<< Recoverable Error >>>
Process model (eth_mac_v2) compilation failed
due to error on source line (20)
Errors given in file (C:\Users\admin\op_admin\tmp\cc_err_5036)
----
<<< Recoverable Error >>>
Process model (ethernet_mac_interface) compilation failed
due to error on source line (20)
Errors given in file (C:\Users\admin\op_admin\tmp\cc_err_5036)
----
<<< Recoverable Error >>>
External code file (ethernet_notif_log_support) compilation failed
due to error on source line (17)
Errors given in file (C:\Users\admin\op_admin\tmp\cc_err_5036)
----
<<< Recoverable Error >>>
External code file (link_delay) compilation failed
due to error on source line (16)
Errors given in file (C:\Users\admin\op_admin\tmp\cc_err_5036)
----
<<< Recoverable Error >>>
External code file (oms_auto_addr_support) compilation failed
due to error on source line (84)
Errors given in file (C:\Users\admin\op_admin\tmp\cc_err_5036)
----
<<< Recoverable Error >>>
External code file (oms_dist_support) compilation failed
due to error on source line (37)
Errors given in file (C:\Users\admin\op_admin\tmp\cc_err_5036)
----
<<< Recoverable Error >>>
External code file (oms_ot_support) compilation failed
due to error on source line (16)
Errors given in file (C:\Users\admin\op_admin\tmp\cc_err_5036)
----
<<< Recoverable Error >>>
External code file (oms_pr) compilation failed
due to error on source line (18)
Errors given in file (C:\Users\admin\op_admin\tmp\cc_err_5036)
----
<<< Recoverable Error >>>
External code file (oms_sim_attr_cache) compilation failed
due to error on source line (14)
Errors given in file (C:\Users\admin\op_admin\tmp\cc_err_5036)
----
<<< Recoverable Error >>>
External code file (oms_string_support) compilation failed
due to error on source line (16)
Errors given in file (C:\Users\admin\op_admin\tmp\cc_err_5036)
----
<<< Recoverable Error >>>
External code file (oms_tan) compilation failed
due to error on source line (20)
Errors given in file (C:\Users\admin\op_admin\tmp\cc_err_5036)
----
<<< Recoverable Error >>>
Object repository construction failed
External code file (C:\Program Files\OPNET\14.5.A\models\std\utilities\oms\oms_tan.ex.c) compilation failed, see error messages in (C:\Users\admin\op_admin\tmp\cc_err_5036)
T (0), EV (-), MOD (NONE), PROC (sim_load_repos_rebuild)
----
<<< Program Abort >>>
Error encountered rebuilding repository -- unable to proceed
T (0), EV (-), MOD (NONE), PROC (sim_load_repos_load)

----
Please help me.

Alireza Rezvani said...

@Morteza

Hi, I think you should recheck the paths. Otherwise, I have no idea

Asiyeh Abi said...

hello
thank you for your comprehensive video. I followed the instructions step by step, but I have problem in license activation.
The version of opnet I installed is 14 and my license is 14.5, at first I thought it might be the problem, but my classmates could activate opnet 14 via license 14.5. The problem is that after running license as administrator, when I open opnet, it can't connect to the license server. My windows is 8.1 64 bits, and the visual studio I installed is 2012,64 bit.
thank you so much

Best regards

Iraj AkbariSohi said...

hello
i cant install it
i did all that you said
but i couldnt do it
can you install it remotely on my computer?
irajakbari3000@gmail.com

Alireza Rezvani said...

@Iraj
Hi, sorry to hear that you were not successful to install OPNET. It is quit easy. Please first check the comments here, may be you have the problem which one of the guys here had before so you can fix the problem based on the discussion here. If you are still not successful to install, please post here what error do you get.

Regarding the installing OPNET remotely, sorry bro it is impossible for me.
Thanks

Iraj AkbariSohi said...

Hello
Thank you for your quick answer.
I have installed windows 8, 64 bit with visual studio 2012.
After set all the variables as you have swrite in the website.
I have open opnet as administrator(not opnet 64 bit).
I Run the sample without the error but when i run my own project i have recived the bellow error (in C:\Users\Iraj\op_admin\tmp):

bind_err_652
Creating library C:\Users\Iraj\Desktop\OLSR1.project\OLSR1.project\OLSR1-OLSR_60_80211a.dev32.i0.nt.lib and object C:\Users\Iraj\Desktop\OLSR1.project\OLSR1.project\OLSR1-OLSR_60_80211a.dev32.i0.nt.exp
LINK : fatal error LNK1207: incompatible PDB format in 'C:\Users\Iraj\Desktop\OLSR1.project\OLSR1.project\OLSR1-OLSR_60_80211a.dev32.i0.nt.pdb'; delete and rebuild

Alireza Rezvani said...

@Iraj,

Sorry I have not seen this error before but I would use OPNET 64-bit

Iraj AkbariSohi said...

it didn't answer also

Alireza Rezvani said...

@Iraj,

Thanks for your comment. I dont know. If you get the answer, please come and write here so other guys who has the same problem and follow your solution.
Thanks

Murtaza cicio─člu said...

Hi,i had followed the steps provided by you but getting error message as:

"cannot enable ets scripting support due to missing files"

how to fix it? can you help?

Alireza Rezvani said...

@ Murtaza

Sorry.. have no idea. I don't work with OPNET any more

yasmeen Shahdad said...
This comment has been removed by the author.
yasmeen Shahdad said...

I followed your video of OPNET 14.5 in Windows 8. Only difference was that i had windows 8.1.
Opnet is installed in program files and Visual Basic in C++ in Program files(x86)
But i made all the necessary changes in env variables.
1. PATH
C:\Program Files(x86)\Microsoft Visual Studio 9.0\Common7\IDE;C:\Program Files(x86)\Microsoft Visual Studio 9.0\VC\BIN;C:\Program Files(x86)\Microsoft Visual Studio 9.0\Common7\Tools;C:\Program Files(x86)\Microsoft Visual Studio 9.0\Common7\Tools\bin;C:\WINDOWS\Microsoft.NET\Framework\v3.5;C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727;C:\Program Files(x86)\Microsoft Visual Studio 9.0\VC\VCPackages;C:\Program Files(x86)\Microsoft SDKs\Windows\v6.0A\bin;

2. LIB
C:\Program Files(x86)\Microsoft Visual Studio 9.0\VC\ATLMFC\LIB;C:\Program Files(x86)\Microsoft Visual Studio 9.0\VC\LIB;C:\Program Files(x86)\Microsoft SDKs\Windows\v6.0A\lib;

3. LIBPATH
C:\WINDOWS\Microsoft.NET\Framework\v3.5;C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727;C:\Program Files(x86)\Microsoft Visual Studio 9.0\VC\ATLMFC\LIB;C:\Program Files(x86)\Microsoft Visual Studio 9.0\VC\LIB;

4. INCLUDE
C:\Program Files(x86)\Microsoft Visual Studio 9.0\VC\ATLMFC\INCLUDE;C:\Program Files(x86)\Microsoft Visual Studio 9.0\VC\INCLUDE;C:\Program Files(x86)\Microsoft Visual Studio 9.0\SDK\v3.5\include;

5. NetSamplePath
C:\Program Files(x86)\Microsoft Visual Studio 9.0\SDK\v3.5;

6. DevEnvDir
C:\Program Files(x86)\Microsoft Visual Studio 9.0\Common7\IDE;

7. FrameworkDir
C:\Windows\Microsoft.NET\Framework;

8. FrameworkSDKDir
C:\Program Files(x86)\Microsoft Visual Studio 9.0\SDK\v3.5;

9. FrameworkVersion
v2.0.500727;

10. VCBUILD_DEFAULT_CFG
Debug^|Win32;
11. VCBUILD_DEFAULT_OPTIONS
/useenv;

12. VCINSTALLDIR
C:\Program Files(x86)\Microsoft Visual Studio 9.0\VC;

13. VSINSTALLDIR
C:\Program Files(x86)\Microsoft Visual Studio 9.0;


When i run opnet i get following 2 messages..

1) Cannot enable ETS Scripting due to missing files. This is because is not included in mod_dirs preference. You may proceed but certain functions may not behave as documented. Then i clicked on OK.

2) After clicking OK i get message "unable to load editor configuration file because the file could not be found"

Please can you assist me ?....